const regex = /https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/(?:www\\.)?instagram\\.com(?:\\\/[^\\\/]+)?\\\/(?:p|tv|reel)\\\/([^\\\/?#&]+)', 'gm')
const str = `https://instagram.com/p/aye83DjauH/?foo=bar#abc
https://www.instagram.com/reel/Chunk8-jurw/
https://www.instagram.com/p/BQ0eAlwhDrw/
https://www.instagram.com/tv/BkfuX9UB-eK/
https://instagram.com/p/-Cmh1cukG2/
http://instagram.com/p/9o6LshA7zy/embed/
https://www.instagram.com/tv/aye83DjauH/
https://www.instagram.com/reel/CDUMkliABpa/
https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}