import re
regex = re.compile(r"https?:\/\/(?:www\.)?instagram\.com(?:\/[^\/]+)?\/(?:p|tv|reel)\/([^\/?#&]+)", flags=re.MULTILINE)
test_str = ("https://instagram.com/p/aye83DjauH/?foo=bar#abc\n"
"https://www.instagram.com/reel/Chunk8-jurw/\n"
"https://www.instagram.com/p/BQ0eAlwhDrw/\n"
"https://www.instagram.com/tv/BkfuX9UB-eK/\n"
"https://instagram.com/p/-Cmh1cukG2/\n"
"http://instagram.com/p/9o6LshA7zy/embed/\n"
"https://www.instagram.com/tv/aye83DjauH/\n"
"https://www.instagram.com/reel/CDUMkliABpa/\n"
"https://www.instagram.com/marvelskies.fc/reel/CWqAgUZgCku/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")