import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0*(?:[2-9]|[1-9]\\d\\d*)$";
final String string = "002\n"
+ "00\n"
+ "001\n"
+ "1\n"
+ "10\n"
+ "100\n"
+ "1000\n"
+ "00100\n"
+ "001000\n"
+ "0000100\n"
+ "000001";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}