$re = '/^0*(?:[2-9]|[1-9]\d\d*)$/m';
$str = '002
00
001
1
10
100
1000
00100
001000
0000100
000001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);