import re
regex = re.compile(r"^0*(?:[2-9]|[1-9]\d\d*)$", flags=re.MULTILINE)
test_str = ("002\n"
"00\n"
"001\n"
"1\n"
"10\n"
"100\n"
"1000\n"
"00100\n"
"001000\n"
"0000100\n"
"000001")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")