// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0*(?:[2-9]|[1-9]\d\d*)$").unwrap();
let string = "002
00
001
1
10
100
1000
00100
001000
0000100
000001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}