using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(m\W*o\W*e\W*d\W*a)";
string input = @"moeda
m!o@e@#d!a
M~O]E;D;XXX
M-O1EDA
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}