// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(m\W*o\W*e\W*d\W*a)").unwrap();
let string = "moeda
m!o@e@#d!a
M~O]E;D;XXX
M-O1EDA
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}