package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(m\W*o\W*e\W*d\W*a)`)
var str = `moeda
m!o@e@#d!a
M~O]E;D;XXX
M-O1EDA
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}