$re = '/(m\W*o\W*e\W*d\W*a)/';
$str = 'moeda
m!o@e@#d!a
M~O]E;D;XXX
M-O1EDA
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);