using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"background:\s*#[a-fA-F0-9]*;";
string input = @".foo {
background:#ffffgg;
}
.bar {
background: #BADA55;
}
.baz {
background: #fff;
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}