// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"background:\s*#[a-fA-F0-9]*;").unwrap();
let string = ".foo {
background:#ffffgg;
}
.bar {
background: #BADA55;
}
.baz {
background: #fff;
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}