package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`background:\s*#[a-fA-F0-9]*;`)
var str = `.foo {
background:#ffffgg;
}
.bar {
background: #BADA55;
}
.baz {
background: #fff;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}