re = /background:\s*#[a-fA-F0-9]*;/
str = '.foo {
background:#ffffgg;
}
.bar {
background: #BADA55;
}
.baz {
background: #fff;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end