using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\( *?(select *?max\( .*?column_name *?\).+) *?\)";
string input = @"value = ( select max( tbl.column_name ) from table tbl where trim(colum2)='value1' and (trim((colum3)))='value3')";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}