$re = '/\( *?(select *?max\( .*?column_name *?\).+) *?\)/m';
$str = 'value = ( select max( tbl.column_name ) from table tbl where trim(colum2)=\'value1\' and (trim((colum3)))=\'value3\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);