const regex = /\( *?(select *?max\( .*?column_name *?\).+) *?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\( *?(select *?max\\( .*?column_name *?\\).+) *?\\)', 'gm')
const str = `value = ( select max( tbl.column_name ) from table tbl where trim(colum2)='value1' and (trim((colum3)))='value3')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}