package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\( *?(select *?max\( .*?column_name *?\).+) *?\)`)
var str = `value = ( select max( tbl.column_name ) from table tbl where trim(colum2)='value1' and (trim((colum3)))='value3')`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}