$re = '/\b(\d\S*) Followers/';
$str = '4 Followers
330 Followers
23.5k Followers
67k Followers
25m Followers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);