import re
regex = re.compile(r"\b(\d\S*) Followers")
test_str = ("4 Followers\n"
"330 Followers\n"
"23.5k Followers\n"
"67k Followers\n"
"25m Followers")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")