re = /\b(\d\S*) Followers/
str = '4 Followers
330 Followers
23.5k Followers
67k Followers
25m Followers'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end