using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)[a-z][\w.-]*(?:\s+[\w.-]+)*";
string input = @"3. line A<br>4. line B<br>5. line C<br>6. line3. garbage<br>7. line<br>8. line END";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}