re = /(?<=\s|^)[a-z][\w.-]*(?:\s+[\w.-]+)*/mi
str = '3. line A<br>4. line B<br>5. line C<br>6. line3. garbage<br>7. line<br>8. line END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end