const regex = /(?<=\s|^)[a-z][\w.-]*(?:\s+[\w.-]+)*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s|^)[a-z][\\w.-]*(?:\\s+[\\w.-]+)*', 'gmi')
const str = `3. line A<br>4. line B<br>5. line C<br>6. line3. garbage<br>7. line<br>8. line END`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}