use strict;
my $str = '3. line A<br>4. line B<br>5. line C<br>6. line3. garbage<br>7. line<br>8. line END';
my $regex = qr/(?<=\s|^)[a-z][\w.-]*(?:\s+[\w.-]+)*/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}