#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-----(?:BEGIN|END) (?<label>(?:(?:TRUSTED |X509 )?(?<t1>CERTIFICATE))|(?:(?:NEW )?CERTIFICATE (?<t2>REQUEST))|(?:X509 (?<t3>CRL)))-----$"
Local $sString = "-----BEGIN CERTIFICATE-----" & @CRLF & _
"-----END CERTIFICATE-----" & @CRLF & _
"-----BEGIN TRUSTED CERTIFICATE-----" & @CRLF & _
"-----END TRUSTED CERTIFICATE-----" & @CRLF & _
"-----BEGIN X509 CERTIFICATE-----" & @CRLF & _
"-----END X509 CERTIFICATE-----" & @CRLF & _
"" & @CRLF & _
"-----BEGIN CERTIFICATE REQUEST-----" & @CRLF & _
"-----END CERTIFICATE REQUEST-----" & @CRLF & _
"-----BEGIN NEW CERTIFICATE REQUEST-----" & @CRLF & _
"-----END NEW CERTIFICATE REQUEST-----" & @CRLF & _
"" & @CRLF & _
"-----BEGIN X509 CRL-----" & @CRLF & _
"-----END X509 CRL-----"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")