import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-----(?:BEGIN|END) (?<label>(?:(?:TRUSTED |X509 )?(?<t1>CERTIFICATE))|(?:(?:NEW )?CERTIFICATE (?<t2>REQUEST))|(?:X509 (?<t3>CRL)))-----$";
final String string = "-----BEGIN CERTIFICATE-----\n"
+ "-----END CERTIFICATE-----\n"
+ "-----BEGIN TRUSTED CERTIFICATE-----\n"
+ "-----END TRUSTED CERTIFICATE-----\n"
+ "-----BEGIN X509 CERTIFICATE-----\n"
+ "-----END X509 CERTIFICATE-----\n\n"
+ "-----BEGIN CERTIFICATE REQUEST-----\n"
+ "-----END CERTIFICATE REQUEST-----\n"
+ "-----BEGIN NEW CERTIFICATE REQUEST-----\n"
+ "-----END NEW CERTIFICATE REQUEST-----\n\n"
+ "-----BEGIN X509 CRL-----\n"
+ "-----END X509 CRL-----";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}