const regex = /^-----(?:BEGIN|END) (?<label>(?:(?:TRUSTED |X509 )?(?<t1>CERTIFICATE))|(?:(?:NEW )?CERTIFICATE (?<t2>REQUEST))|(?:X509 (?<t3>CRL)))-----$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-----(?:BEGIN|END) (?<label>(?:(?:TRUSTED |X509 )?(?<t1>CERTIFICATE))|(?:(?:NEW )?CERTIFICATE (?<t2>REQUEST))|(?:X509 (?<t3>CRL)))-----$', 'gm')
const str = `-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
-----BEGIN TRUSTED CERTIFICATE-----
-----END TRUSTED CERTIFICATE-----
-----BEGIN X509 CERTIFICATE-----
-----END X509 CERTIFICATE-----
-----BEGIN CERTIFICATE REQUEST-----
-----END CERTIFICATE REQUEST-----
-----BEGIN NEW CERTIFICATE REQUEST-----
-----END NEW CERTIFICATE REQUEST-----
-----BEGIN X509 CRL-----
-----END X509 CRL-----`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}