# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-----(?:BEGIN|END) (?<label>(?:(?:TRUSTED |X509 )?(?<t1>CERTIFICATE))|(?:(?:NEW )?CERTIFICATE (?<t2>REQUEST))|(?:X509 (?<t3>CRL)))-----$"
test_str = ("-----BEGIN CERTIFICATE-----\n"
"-----END CERTIFICATE-----\n"
"-----BEGIN TRUSTED CERTIFICATE-----\n"
"-----END TRUSTED CERTIFICATE-----\n"
"-----BEGIN X509 CERTIFICATE-----\n"
"-----END X509 CERTIFICATE-----\n\n"
"-----BEGIN CERTIFICATE REQUEST-----\n"
"-----END CERTIFICATE REQUEST-----\n"
"-----BEGIN NEW CERTIFICATE REQUEST-----\n"
"-----END NEW CERTIFICATE REQUEST-----\n\n"
"-----BEGIN X509 CRL-----\n"
"-----END X509 CRL-----")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.