package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-](?:webkit|moz|op|ms)(?:[-][a-zA-Z0-9]{2,})+`)
var str = `-webkit-aultofill
-moz-read-only
-moz
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}