re = /[-](?:webkit|moz|op|ms)(?:[-][a-zA-Z0-9]{2,})+/m
str = '-webkit-aultofill
-moz-read-only
-moz
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end