$re = '/[-](?:webkit|moz|op|ms)(?:[-][a-zA-Z0-9]{2,})+/m';
$str = '-webkit-aultofill
-moz-read-only
-moz
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);