using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\[]\w+\)[^\]]";
string input = @"<table
[box]=""teamsTypes""
[(bananInBox)]=""bananInBox""
(banan)=""createDialog()""
class=""class""
mat-table
>
</table>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}