package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\[]\w+\)[^\]]`)
var str = `<table
[box]="teamsTypes"
[(bananInBox)]="bananInBox"
(banan)="createDialog()"
class="class"
mat-table
>
</table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}