re = /[^\[]\w+\)[^\]]/
str = '<table
[box]="teamsTypes"
[(bananInBox)]="bananInBox"
(banan)="createDialog()"
class="class"
mat-table
>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end