# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+\[.*?(?=\S+$)//gm;t' <<< "15-16-00-014716 AND15- [ ] (5) Description of 16-00-014715
15-16-00-014716 AND15- [ ] (5) Description of 1600014715"