import Foundation
let pattern = #"\s+\[.*?(?=\S+$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
15-16-00-014716 AND15- [ ] (5) Description of 16-00-014715
15-16-00-014716 AND15- [ ] (5) Description of 1600014715
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)