using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+\[.*?(?=\S+$)";
string substitution = @"";
string input = @"15-16-00-014716 AND15- [ ] (5) Description of 16-00-014715
15-16-00-014716 AND15- [ ] (5) Description of 1600014715";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}