import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d+(?:\\|\\d+)?,)+\\d+(?:\\|\\d+)?$";
final String string = "111|222,333,444\n\n"
+ "111\n"
+ "111,222|333,\n"
+ "111,222,333|\n"
+ ",111,222,333|444\n"
+ "|111,222|333,444\n\n"
+ "111,222|333,444\n"
+ "111|222,333,444";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}