re = /^(?:\d+(?:\|\d+)?,)+\d+(?:\|\d+)?$/m
str = '111|222,333,444
111
111,222|333,
111,222,333|
,111,222,333|444
|111,222|333,444
111,222|333,444
111|222,333,444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end