$re = '/^(?:\d+(?:\|\d+)?,)+\d+(?:\|\d+)?$/m';
$str = '111|222,333,444
111
111,222|333,
111,222,333|
,111,222,333|444
|111,222|333,444
111,222|333,444
111|222,333,444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);