use strict;
my $str = '@include(\'xxx/yyy/asd/asdf/asdf/asdf/asdf\')';
my $regex = qr/(@include\('[^']*)\/([^']*'\))/mp;
my $subst = '$1.$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";