import re
regex = re.compile(r"(@include\('[^']*)\/([^']*'\))", flags=re.MULTILINE)
test_str = "@include('xxx/yyy/asd/asdf/asdf/asdf/asdf')"
subst = "$1.$2"
result = regex.sub(subst, test_str)
if result:
print(result)