using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^gpg: key ([[:xdigit:]]{16}):.+<(.+)>";
string input = @"gpg: key ED444FF07D8D0BF6: public key ""Kali Linux Repository <devel@kali.org>"" imported";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}