$re = '/^gpg: key ([[:xdigit:]]{16}):.+<(.+)>/m';
$str = 'gpg: key ED444FF07D8D0BF6: public key "Kali Linux Repository <devel@kali.org>" imported';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);