// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^gpg: key ([[:xdigit:]]{16}):.+<(.+)>").unwrap();
let string = "gpg: key ED444FF07D8D0BF6: public key \"Kali Linux Repository <devel@kali.org>\" imported";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}