package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^gpg: key ([[:xdigit:]]{16}):.+<(.+)>`)
var str = `gpg: key ED444FF07D8D0BF6: public key "Kali Linux Repository <devel@kali.org>" imported`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}