using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The\sfirst\svalue\sis (?<from>[^\s]+).+(?<to>\d)";
string input = @"The first value is 0.00 and The second value is 0"",""origin"":""rep"",""source_instance"":""0""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}