import re
regex = re.compile(r"The\sfirst\svalue\sis (?<from>[^\s]+).+(?<to>\d)", flags=re.MULTILINE)
test_str = "The first value is 0.00 and The second value is 0\",\"origin\":\"rep\",\"source_instance\":\"0\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")