re = /The\sfirst\svalue\sis (?<from>[^\s]+).+(?<to>\d)/m
str = 'The first value is 0.00 and The second value is 0","origin":"rep","source_instance":"0"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end